Installation

Dependencies

To use the ICCLIM you first need to install the following python libraries:

Installation (Linux, OS X)

Note

Make sure that Python 3.6+ and GCC are installed.

  1. Go to https://github.com/cerfacs-globc/icclim/releases/.
  2. Download the last release: click to Source code (zip) or Source code (tar.gz).
  3. Extract the file.
  4. Go to extracted directory.
  5. Run the following commands:
gcc -fPIC -g -c -Wall ./icclim/libC.c -o ./icclim/libC.o

gcc -shared -o ./icclim/libC.so ./icclim/libC.o

[sudo] python setup.py install

or if you don’t have root or sudo access, as a normal user:

python setup.py install --user
  1. Check if the library is installed correctly:
>>> from icclim import icclim

To get the version of installed library, do the following:

>>> icclim.__version__
4.2.13

Note

ICCLIM was not tested on Windows platform…